summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/ruby
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2014-05-20 15:25:27 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-05-24 00:27:14 -0400
commit2cffe3418bc2ca116bfe8d05864a81f99ec100c1 (patch)
treee19063596007aee5705e10cb00d527f8025d485b /meta-openstack/recipes-devtools/ruby
parent7fbe5a11b481504522da1fd4c8a17008dcd8365e (diff)
downloadmeta-cloud-services-2cffe3418bc2ca116bfe8d05864a81f99ec100c1.tar.gz
Ruby/chef solo: Add recipes-devtools/ruby/slop_git.bb
A simple option parser with an simple syntax and API. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/ruby')
-rw-r--r--meta-openstack/recipes-devtools/ruby/slop_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/ruby/slop_git.bb b/meta-openstack/recipes-devtools/ruby/slop_git.bb
new file mode 100644
index 0000000..eff1bee
--- /dev/null
+++ b/meta-openstack/recipes-devtools/ruby/slop_git.bb
@@ -0,0 +1,24 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4SUMMARY = "A simple option parser with an simple syntax and API."
5DESCRIPTION = "A simple option parser with an simple syntax and API."
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=66a8da2a5bee25570ffc35aa5426d176"
9
10PR = "r0"
11
12BPV = "3.5.0"
13PV = "${BPV}"
14SRCREV = "a009587ec2c0cf07b38bd8f0b59baa244fdbce51"
15
16S = "${WORKDIR}/git"
17
18SRC_URI = " \
19 git://github.com/leejarvis/slop.git \
20 "
21
22inherit ruby
23
24BBCLASSEXTEND = "native"