summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-06 12:02:19 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-07 15:13:47 -0500
commitf01987abfa101d77a02ccaae310d040902d2966e (patch)
tree183d323b1d906dba6d382c9d0d8be8a7993e6853 /meta-openstack/recipes-devtools/python
parent7082e92d5ab465d4475b902fe767902480f3c12e (diff)
downloadmeta-cloud-services-f01987abfa101d77a02ccaae310d040902d2966e.tar.gz
python-nova: sudoers.d match dir ownership/perms
The sudoers.d directory is for all intents and purposes created and owned by the sudo package. We must therefor ensure we match the ownership and perms which sudo used to install this directory. Currently we don't so this results in an error when assembling the filesystem: file /etc/sudoers.d conflicts between attempted installs of \ nova-common-12.0.0+git0+6df6ad3ff3-r0.core2_64 and \ sudo-1.8.20p2-r0.core2_64 Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index c1f4de1..f3a6b86 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -88,7 +88,7 @@ do_install_append() {
88 chown root:root $NOVA_CONF_DIR/rootwrap.conf 88 chown root:root $NOVA_CONF_DIR/rootwrap.conf
89 89
90 # Set up the rootwrap sudoers for nova 90 # Set up the rootwrap sudoers for nova
91 install -d ${D}${sysconfdir}/sudoers.d 91 install -d -m 750 ${D}${sysconfdir}/sudoers.d
92 touch ${D}${sysconfdir}/sudoers.d/nova-rootwrap 92 touch ${D}${sysconfdir}/sudoers.d/nova-rootwrap
93 chmod 0440 ${D}${sysconfdir}/sudoers.d/nova-rootwrap 93 chmod 0440 ${D}${sysconfdir}/sudoers.d/nova-rootwrap
94 chown root:root ${D}${sysconfdir}/sudoers.d/nova-rootwrap 94 chown root:root ${D}${sysconfdir}/sudoers.d/nova-rootwrap