summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-03 17:04:22 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-09 09:45:08 -0400
commitebe7098fb5a3199f41a2fa1f36b8c594e63aba2d (patch)
tree9660e4339cd65718257268e9bf18cb1083f9f606 /meta-openstack/recipes-devtools/python
parentc4e3732386af0df68a6d0c8ef63a0533b9847018 (diff)
downloadmeta-cloud-services-ebe7098fb5a3199f41a2fa1f36b8c594e63aba2d.tar.gz
keystone: fix location of files for tests
Keystone tests define the location of certificate files as the location of the files in the source tree. However, when installed on the system files are put in different locations. This change patches the configuration file for some tests to contain the full path to the tests directories. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone/keystone-fix-location-of-files-for-tests.patch34
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb3
2 files changed, 37 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone/keystone-fix-location-of-files-for-tests.patch b/meta-openstack/recipes-devtools/python/python-keystone/keystone-fix-location-of-files-for-tests.patch
new file mode 100644
index 0000000..3e73696
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystone/keystone-fix-location-of-files-for-tests.patch
@@ -0,0 +1,34 @@
1From 205ee3cfa4c7efd39f5fe991b53327c1bd771f97 Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Tue, 3 Jun 2014 16:19:54 -0400
4Subject: [PATCH] keystone: fix location of files for tests
5
6Keystone tests define the location of certificate files
7as the location of the files in the source tree. However,
8when installed on the system these files are put in a
9different location. This patch provides a symbol, which
10is replaced, for the base path of the location of the test
11files.
12
13Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
14---
15 keystone/tests/test_overrides.conf | 6 +++---
16 1 file changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/keystone/tests/test_overrides.conf b/keystone/tests/test_overrides.conf
19index 801b0d2..ba35343 100644
20--- a/keystone/tests/test_overrides.conf
21+++ b/keystone/tests/test_overrides.conf
22@@ -21,6 +21,6 @@ debug_cache_backend = True
23 proxies = keystone.tests.test_cache.CacheIsolatingProxy
24
25 [signing]
26-certfile = ../../examples/pki/certs/signing_cert.pem
27-keyfile = ../../examples/pki/private/signing_key.pem
28-ca_certs = ../../examples/pki/certs/cacert.pem
29+certfile = %KEYSTONE_PACKAGE_DIR%/examples/pki/certs/signing_cert.pem
30+keyfile = %KEYSTONE_PACKAGE_DIR%/examples/pki/private/signing_key.pem
31+ca_certs = %KEYSTONE_PACKAGE_DIR%/examples/pki/certs/cacert.pem
32--
331.9.3
34
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 3f4220c..4c28f78 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
13 file://keystone \ 13 file://keystone \
14 file://openrc \ 14 file://openrc \
15 file://keystone-search-in-etc-directory-for-config-files.patch \ 15 file://keystone-search-in-etc-directory-for-config-files.patch \
16 file://keystone-fix-location-of-files-for-tests.patch \
16 " 17 "
17 18
18SRCREV="a96d1a44bc0f074729c312e5c2a0f0875edf1765" 19SRCREV="a96d1a44bc0f074729c312e5c2a0f0875edf1765"
@@ -58,6 +59,8 @@ do_install_append() {
58 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone 59 install -m 0755 ${WORKDIR}/keystone ${D}${sysconfdir}/init.d/keystone
59 fi 60 fi
60 61
62 sed -e "s:%KEYSTONE_PACKAGE_DIR%:${PYTHON_SITEPACKAGES_DIR}/keystone:g" -i ${KEYSTONE_PACKAGE_DIR}/tests/test_overrides.conf
63
61 cp run_tests.sh ${KEYSTONE_CONF_DIR} 64 cp run_tests.sh ${KEYSTONE_CONF_DIR}
62} 65}
63 66