summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-09-04 10:45:49 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-05 09:56:02 -0400
commitdbd23cfb3589c19317241cf2150500efc9963010 (patch)
tree83d80b826f01af7c95b98c6a43d1bee8829a6062 /meta-openstack/recipes-devtools/python
parent2c9c61321a17db50fb74476fe1136fcf6571763b (diff)
downloadmeta-cloud-services-dbd23cfb3589c19317241cf2150500efc9963010.tar.gz
python-eventlet: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-eventlet.inc10
-rw-r--r--meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb12
-rw-r--r--meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb2
3 files changed, 14 insertions, 10 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-eventlet.inc b/meta-openstack/recipes-devtools/python/python-eventlet.inc
new file mode 100644
index 0000000..fd1bf39
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-eventlet.inc
@@ -0,0 +1,10 @@
1DESCRIPTION = "Highly concurrent networking library"
2HOMEPAGE = "http://pypi.python.org/pypi/eventlet"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
6
7SRC_URI[md5sum] = "8d7145af6506d5418c5a6bee7bf0b7e7"
8SRC_URI[sha256sum] = "6c9c625af48424c4680d89314dbe45a76cc990cf002489f9469ff214b044ffc1"
9
10inherit pypi
diff --git a/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb b/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb
index d2878b6..d9c9383 100644
--- a/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-eventlet_0.25.1.bb
@@ -1,10 +1,2 @@
1DESCRIPTION = "Highly concurrent networking library" 1inherit setuptools
2HOMEPAGE = "http://pypi.python.org/pypi/eventlet" 2require python-eventlet.inc
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778"
6
7SRC_URI[md5sum] = "8d7145af6506d5418c5a6bee7bf0b7e7"
8SRC_URI[sha256sum] = "6c9c625af48424c4680d89314dbe45a76cc990cf002489f9469ff214b044ffc1"
9
10inherit setuptools pypi
diff --git a/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb b/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb
new file mode 100644
index 0000000..c5fe598
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-eventlet_0.25.1.bb
@@ -0,0 +1,2 @@
1inherit setuptools3
2require python-eventlet.inc