diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2015-04-08 14:49:32 +0800 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2015-04-08 10:36:55 -0400 |
commit | c0e47b45c31e0fbbb3f03993fc9957278e6c2990 (patch) | |
tree | 4f63ab1665ddb267a12c2abf9a4bd821d1f2b330 /meta-openstack/recipes-devtools/python | |
parent | d8bf5c732b3399820306a2ef2b540e6d1489ba96 (diff) | |
download | meta-cloud-services-c0e47b45c31e0fbbb3f03993fc9957278e6c2990.tar.gz |
Add missing dependencies for keystone, fixtures and testtools
These missing dependencies are found when running keystone tests:
File "/usr/lib/python2.7/site-packages/keystone/tests/unit/core.py", line 28, in <module>
import fixtures
ImportError: No module named fixtures
File "/usr/lib/python2.7/site-packages/keystone/tests/unit/core.py", line 32, in <module>
import oslotest.base as oslotest
ImportError: No module named oslotest.base
File "/usr/lib/python2.7/site-packages/fixtures/fixture.py", line 26, in <module>
from testtools.compat import (
ImportError: No module named testtools.compat
File "/usr/lib/python2.7/site-packages/testtools/compat.py", line 31, in <module>
from extras import try_imports
ImportError: No module named extras
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
3 files changed, 6 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-fixtures_1.0.0.bb b/meta-openstack/recipes-devtools/python/python-fixtures_1.0.0.bb index a3d6a34..fe1c8d1 100644 --- a/meta-openstack/recipes-devtools/python/python-fixtures_1.0.0.bb +++ b/meta-openstack/recipes-devtools/python/python-fixtures_1.0.0.bb | |||
@@ -20,3 +20,5 @@ DISTUTILS_INSTALL_ARGS = "--root=${D} \ | |||
20 | --prefix=${prefix} \ | 20 | --prefix=${prefix} \ |
21 | --install-lib=${PYTHON_SITEPACKAGES_DIR} \ | 21 | --install-lib=${PYTHON_SITEPACKAGES_DIR} \ |
22 | --install-data=${datadir}" | 22 | --install-data=${datadir}" |
23 | |||
24 | RDEPENDS_${PN} += "python-testtools" | ||
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb index e5896df..1f012cc 100644 --- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb +++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb | |||
@@ -284,6 +284,8 @@ RDEPENDS_${PN} += " \ | |||
284 | python-pysaml2 \ | 284 | python-pysaml2 \ |
285 | python-oslo.utils \ | 285 | python-oslo.utils \ |
286 | python-oauthlib \ | 286 | python-oauthlib \ |
287 | python-fixtures \ | ||
288 | python-oslotest \ | ||
287 | " | 289 | " |
288 | 290 | ||
289 | RDEPENDS_${SRCNAME}-tests += " bash" | 291 | RDEPENDS_${SRCNAME}-tests += " bash" |
diff --git a/meta-openstack/recipes-devtools/python/python-testtools_0.9.33.bb b/meta-openstack/recipes-devtools/python/python-testtools_0.9.33.bb index 7e359b4..48663e9 100644 --- a/meta-openstack/recipes-devtools/python/python-testtools_0.9.33.bb +++ b/meta-openstack/recipes-devtools/python/python-testtools_0.9.33.bb | |||
@@ -16,3 +16,5 @@ SRC_URI[sha256sum] = "5b62231fea71ccb2361d48286481b198ccb8768bf81f8aaec1c8d5fb98 | |||
16 | S = "${WORKDIR}/${SRCNAME}-${PV}" | 16 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
17 | 17 | ||
18 | inherit setuptools | 18 | inherit setuptools |
19 | |||
20 | RDEPENDS_${PN} += "python-extras" | ||