summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-05-30 12:55:02 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 09:24:46 -0400
commit74d156db9f696cf9b3a4fbe9c006605198e261da (patch)
treeb78c8a58ce411df0298d1206fef8c9d9dd3ca20a /meta-openstack/recipes-devtools/python
parentfc484b6e10fdb39fbcb46c76c06501f27f857da5 (diff)
downloadmeta-cloud-services-74d156db9f696cf9b3a4fbe9c006605198e261da.tar.gz
nose-exclude: add plugin for nose to exclude directories
Nose is a package to support unit testing of python source code. Node-exclude is a plugin extending Nose to specify directories to exclude from testing via the command line. Some packages require this plugin to be installed in order to run all the tests successfully. This fix creates recipe to install the node-exclude plugin on the target system. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-nose-exclude_0.2.0.bb30
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index f2d4646..3924fc8 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -17,6 +17,7 @@ RDEPENDS_${PN} += "python-django \
17 python-cinderclient \ 17 python-cinderclient \
18 python-glanceclient \ 18 python-glanceclient \
19 python-keystoneclient \ 19 python-keystoneclient \
20 python-nose-exclude \
20 python-novaclient \ 21 python-novaclient \
21 python-neutronclient \ 22 python-neutronclient \
22 python-heatclient \ 23 python-heatclient \
@@ -131,6 +132,7 @@ RDEPENDS_${PN} += " python-django \
131 python-keystoneclient \ 132 python-keystoneclient \
132 python-lesscpy \ 133 python-lesscpy \
133 python-novaclient \ 134 python-novaclient \
135 python-nose-exclude \
134 python-neutronclient \ 136 python-neutronclient \
135 python-pytz \ 137 python-pytz \
136 python-six \ 138 python-six \
diff --git a/meta-openstack/recipes-devtools/python/python-nose-exclude_0.2.0.bb b/meta-openstack/recipes-devtools/python/python-nose-exclude_0.2.0.bb
new file mode 100644
index 0000000..33f277b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-nose-exclude_0.2.0.bb
@@ -0,0 +1,30 @@
1#
2# Copyright (C) 2014 Wind River Systems, Inc.
3#
4DESCRIPTION = "Nose plugin that allows you to easily specify directories to be excluded from testing."
5HOMEPAGE = "http://bitbucket.org/kgrandis/nose-exclude"
6SECTION = "devel/python"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780"
9
10PR = "r0"
11SRCNAME = "nose-exclude"
12
13SRC_URI = "http://pypi.python.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
14 "
15
16SRC_URI[md5sum] = "c8d798c3e29ac82dd5c7bf98a99404af"
17SRC_URI[sha256sum] = "27babdc53e0741ed09d21b7fdb5d244aabb1679f67ef81289f0f34e50aca51c9"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit setuptools
22
23DEPENDS += " \
24 python-pip \
25 "
26
27RDEPENDS_${PN} += " \
28 python-nose \
29 "
30