summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-04-04 16:01:21 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-09 10:48:36 -0400
commit68a36eed8763e88ef0edfa5da82ca77a56ea373b (patch)
tree1168c486b788a4b102c615c182207822eecf9758 /meta-openstack/recipes-devtools/python
parent741ac89ba769bba01cbc0b769b908a568ab30c4d (diff)
downloadmeta-cloud-services-68a36eed8763e88ef0edfa5da82ca77a56ea373b.tar.gz
python-neutron: Don't start the neutron services until init is done
Starting the various neutron services prior to completing the work as part of neutron-init/neutron-init.service will only result in the services spewing python errors. Disable the systemd services in the recipe and have the neutron-init script enable these services for subsequent boots. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron/neutron-init15
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb7
2 files changed, 17 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-neutron/neutron-init b/meta-openstack/recipes-devtools/python/python-neutron/neutron-init
index fe98dcb..d0ae023 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron/neutron-init
+++ b/meta-openstack/recipes-devtools/python/python-neutron/neutron-init
@@ -44,8 +44,13 @@ sudo -u ${NEUTRON_USER} neutron-db-manage --config-file /etc/neutron/neutron.con
44HOME=${ROOT_HOME} rabbitmqctl add_user openstack ${ADMIN_PASSWORD} 44HOME=${ROOT_HOME} rabbitmqctl add_user openstack ${ADMIN_PASSWORD}
45HOME=${ROOT_HOME} rabbitmqctl set_permissions openstack ".*" ".*" ".*" 45HOME=${ROOT_HOME} rabbitmqctl set_permissions openstack ".*" ".*" ".*"
46 46
47#systemctl restart nova-api 47# enable and start the various services
48systemctl restart neutron-server 48systemctl enable neutron-server
49systemctl restart neutron-linuxbridge-agent 49systemctl enable neutron-linuxbridge-agent
50systemctl restart neutron-dhcp-agent 50systemctl enable neutron-dhcp-agent
51systemctl restart neutron-metadata-agent 51systemctl enable neutron-metadata-agent
52
53systemctl start neutron-server
54systemctl start neutron-linuxbridge-agent
55systemctl start neutron-dhcp-agent
56systemctl start neutron-metadata-agent
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index edf9096..a054551 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -418,5 +418,12 @@ SYSTEMD_SERVICE_${SRCNAME}-linuxbridge-agent = "neutron-linuxbridge-agent.servic
418SYSTEMD_SERVICE_${SRCNAME}-metadata-agent = "neutron-metadata-agent.service" 418SYSTEMD_SERVICE_${SRCNAME}-metadata-agent = "neutron-metadata-agent.service"
419SYSTEMD_SERVICE_${SRCNAME}-setup = "neutron-init.service" 419SYSTEMD_SERVICE_${SRCNAME}-setup = "neutron-init.service"
420 420
421# Disable unconfigured services
422SYSTEMD_AUTO_ENABLE_${SRCNAME}-server = "disable"
423SYSTEMD_AUTO_ENABLE_${SRCNAME}-dhcp-agent = "disable"
424SYSTEMD_AUTO_ENABLE_${SRCNAME}-linuxbridge-agent = "disable"
425SYSTEMD_AUTO_ENABLE_${SRCNAME}-metadata-agent = "disable"
426
427
421MONITOR_SERVICE_PACKAGES = "${SRCNAME}" 428MONITOR_SERVICE_PACKAGES = "${SRCNAME}"
422MONITOR_SERVICE_${SRCNAME} = "neutron" 429MONITOR_SERVICE_${SRCNAME} = "neutron"