summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorKeith Holman <Keith.Holman@windriver.com>2014-06-04 11:34:02 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-09 09:45:08 -0400
commit68093df0df2c3b9765cf5ca1728cfee12da322bc (patch)
tree128a9e771d3b6f8ea23dabd0a2434f57a8462512 /meta-openstack/recipes-devtools/python
parentc77a07631e26862073e5c1bbfece1f94da0d3208 (diff)
downloadmeta-cloud-services-68093df0df2c3b9765cf5ca1728cfee12da322bc.tar.gz
keystone: remove git commands from tests
When running the keystone tests, the tests ensures that keystone is being tested against the latest version of keystone-client available by downloading keystone-client from source using git. However, on the target system keystone-client is installed as a separate package and it is undesirable to download a newer version to test against. This fix comments out the portion of the testing code that attempts to retrieve keystone-client from source code using git. Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone/keystone-remove-git-commands-in-tests.patch42
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb1
2 files changed, 43 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-keystone/keystone-remove-git-commands-in-tests.patch b/meta-openstack/recipes-devtools/python/python-keystone/keystone-remove-git-commands-in-tests.patch
new file mode 100644
index 0000000..5605950
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-keystone/keystone-remove-git-commands-in-tests.patch
@@ -0,0 +1,42 @@
1From d2ee135a3c97f714e6da59adf45a91a2f1632057 Mon Sep 17 00:00:00 2001
2From: Keith Holman <Keith.Holman@windriver.com>
3Date: Wed, 4 Jun 2014 11:30:53 -0400
4Subject: [PATCH] keystone: remove git commands in tests
5
6Keystone tests are designed to be used during development
7and will use git to download the latest keystoneclient from
8source to test against. However, on the system installation
9we install keystone-client as a separate package, and do not
10want to download an external version to test. In order to
11test against the version installed as a separate package,
12remove the git calls that clone the keystone-client repository
13and just returned the desired directory.
14
15Signed-off-by: Keith Holman <Keith.Holman@windriver.com>
16---
17 keystone/tests/core.py | 2 ++
18 1 file changed, 2 insertions(+)
19
20diff --git a/keystone/tests/core.py b/keystone/tests/core.py
21index 860f68d..9aa54db 100644
22--- a/keystone/tests/core.py
23+++ b/keystone/tests/core.py
24@@ -109,6 +109,7 @@ def checkout_vendor(repo, rev):
25
26 working_dir = os.getcwd()
27 revdir = os.path.join(VENDOR, '%s-%s' % (name, rev.replace('/', '_')))
28+ """
29 modcheck = os.path.join(VENDOR, '.%s-%s' % (name, rev.replace('/', '_')))
30 try:
31 if os.path.exists(modcheck):
32@@ -129,6 +130,7 @@ def checkout_vendor(repo, rev):
33 fd.write('1')
34 except environment.subprocess.CalledProcessError:
35 LOG.warning(_('Failed to checkout %s'), repo)
36+ """
37 cd(working_dir)
38 return revdir
39
40--
411.9.3
42
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index e37e658..9360aae 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -14,6 +14,7 @@ SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
14 file://openrc \ 14 file://openrc \
15 file://keystone-search-in-etc-directory-for-config-files.patch \ 15 file://keystone-search-in-etc-directory-for-config-files.patch \
16 file://keystone-fix-location-of-files-for-tests.patch \ 16 file://keystone-fix-location-of-files-for-tests.patch \
17 file://keystone-remove-git-commands-in-tests.patch \
17 " 18 "
18 19
19SRCREV="a96d1a44bc0f074729c312e5c2a0f0875edf1765" 20SRCREV="a96d1a44bc0f074729c312e5c2a0f0875edf1765"