summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-07-17 03:41:26 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-20 14:50:08 -0400
commit527ad686d812cd88dfa4d54411ed2548a7445992 (patch)
tree1f575ed1fdacaa3396b75b558fd878939097d480 /meta-openstack/recipes-devtools/python
parentd4ddf6c7f1484f453b5ecab1a5ef6d313cf6d86a (diff)
downloadmeta-cloud-services-527ad686d812cd88dfa4d54411ed2548a7445992.tar.gz
python3-boto: Change to python3
-License-Update: There is no LICENSE file in the package provided by pypi, and it is changed to PKG-INFO. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-boto_git.bb20
-rw-r--r--meta-openstack/recipes-devtools/python/python3-boto_2.49.0.bb21
2 files changed, 21 insertions, 20 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-boto_git.bb b/meta-openstack/recipes-devtools/python/python-boto_git.bb
deleted file mode 100644
index 77e2043..0000000
--- a/meta-openstack/recipes-devtools/python/python-boto_git.bb
+++ /dev/null
@@ -1,20 +0,0 @@
1DESCRIPTION = "Amazon Web Services API"
2HOMEPAGE = "https://github.com/boto/boto"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=348302dddd421665d3c9b636a2e55832"
6
7SRCREV = "b5852b0aa5ac91f462b28ac9decee33d872dec4d"
8PV = "2.8.0+git${SRCPV}"
9PR = "r0"
10SRCNAME = "boto"
11
12SRC_URI = "git://github.com/boto/boto.git;protocol=git"
13
14SRC_URI[md5sum] = "5528f3010c42dd0ed7b188a6917295f1"
15SRC_URI[sha256sum] = "4d6d38aa8e9e536a27a9737eb4222f896417841fed9a12eedcb619ba8fb68a39"
16
17S = "${WORKDIR}/git"
18
19inherit setuptools3
20
diff --git a/meta-openstack/recipes-devtools/python/python3-boto_2.49.0.bb b/meta-openstack/recipes-devtools/python/python3-boto_2.49.0.bb
new file mode 100644
index 0000000..fe09e9f
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-boto_2.49.0.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "Amazon Web Services API"
2HOMEPAGE = "https://github.com/boto/boto"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a1067d091272fcce8cc3d88d7e6fdc01"
6
7SRC_URI[md5sum] = "e9b79f80198da059d9a8055a5352fd6d"
8SRC_URI[sha256sum] = "ea0d3b40a2d852767be77ca343b58a9e3a4b00d9db440efb8da74b4e58025e5a"
9
10RDEPENDS_${PN} += "\
11 python3-json \
12 python3-netclient \
13 python3-threading \
14 python3-xml \
15 python3-logging \
16 python3-pickle \
17 python3-netserver \
18"
19
20inherit setuptools3 pypi
21