summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-01-06 15:49:20 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-01-08 16:24:32 -0500
commit49d86bc69c0a2ba8718437ffd207902766a50b6b (patch)
tree4a8788280592316f16cea08de1450b63f27fadf8 /meta-openstack/recipes-devtools/python
parent005d8e96f11c15ab2cf9ef11e960db41578bda11 (diff)
downloadmeta-cloud-services-49d86bc69c0a2ba8718437ffd207902766a50b6b.tar.gz
python-xstatic-font-awesome: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-font-awesome.inc22
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb24
-rw-r--r--meta-openstack/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb2
3 files changed, 26 insertions, 22 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome.inc b/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome.inc
new file mode 100644
index 0000000..57fae23
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome.inc
@@ -0,0 +1,22 @@
1DESCRIPTION = "Font Awesome icons packaged for setuptools (easy_install) / pip."
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Font-Awesome"
3SECTION = "devel/python"
4LICENSE = "OFL-1.1"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/OFL-1.1;md5=fac3a519e5e9eb96316656e0ca4f2b90"
6
7PYPI_PACKAGE = "XStatic-Font-Awesome"
8
9SRC_URI[md5sum] = "141a0e9a7e21e82f922573a00ae0c166"
10SRC_URI[sha256sum] = "e01fb480caaa7c7963dcb3328a4700e631bef6070db0e8b685816d220e685f6c"
11
12inherit pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 ${PYTHON_PN}-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb b/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
index 76ae529..cc342ac 100644
--- a/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-font-awesome_4.7.0.0.bb
@@ -1,22 +1,2 @@
1DESCRIPTION = "Font Awesome icons packaged for setuptools (easy_install) / pip." 1require python-xstatic-font-awesome.inc
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Font-Awesome" 2inherit setuptools
3SECTION = "devel/python"
4LICENSE = "OFL-1.1"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/OFL-1.1;md5=fac3a519e5e9eb96316656e0ca4f2b90"
6
7PYPI_PACKAGE = "XStatic-Font-Awesome"
8
9SRC_URI[md5sum] = "141a0e9a7e21e82f922573a00ae0c166"
10SRC_URI[sha256sum] = "e01fb480caaa7c7963dcb3328a4700e631bef6070db0e8b685816d220e685f6c"
11
12inherit setuptools pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 python-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "
diff --git a/meta-openstack/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb b/meta-openstack/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb
new file mode 100644
index 0000000..b2998f6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-xstatic-font-awesome_4.7.0.0.bb
@@ -0,0 +1,2 @@
1require python-xstatic-font-awesome.inc
2inherit setuptools3