summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-02-21 00:41:50 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-02-21 00:42:47 -0500
commit441977d076e5c0aeace44ba65d301b5c6c61d59f (patch)
treed3cd21ff7d4aed5e65ff243cd5966b01970e9462 /meta-openstack/recipes-devtools/python
parentdc8c4840c582677c7bfcb8870b3041d3e62c86f9 (diff)
downloadmeta-cloud-services-441977d076e5c0aeace44ba65d301b5c6c61d59f.tar.gz
QA: fix build and runtime warnings
oe-core now warns on detected missing runtime and build time warnings. So we update our recipes to have these missingn deps (largely bash). Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ceilometer_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-cinder_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-glance_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-heat_git.bb3
-rw-r--r--meta-openstack/recipes-devtools/python/python-horizon_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystone_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-neutron_git.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-nova_git.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb2
-rw-r--r--meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb1
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb1
12 files changed, 20 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
index 48051dd..5c6fbbb 100644
--- a/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-ceilometer_git.bb
@@ -138,6 +138,8 @@ PACKAGES += "${SRCNAME}-agent-notification"
138PACKAGES += "${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller" 138PACKAGES += "${SRCNAME}-collector ${SRCNAME}-compute ${SRCNAME}-controller"
139PACKAGES += " ${SRCNAME}-reseller" 139PACKAGES += " ${SRCNAME}-reseller"
140 140
141RDEPENDS_${SRCNAME}-tests += " bash"
142
141ALLOW_EMPTY_${SRCNAME}-setup = "1" 143ALLOW_EMPTY_${SRCNAME}-setup = "1"
142ALLOW_EMPTY_${SRCNAME}-reseller = "1" 144ALLOW_EMPTY_${SRCNAME}-reseller = "1"
143ALLOW_EMPTY_${SRCNAME}-tests = "1" 145ALLOW_EMPTY_${SRCNAME}-tests = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-cinder_git.bb b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
index 4769a82..a51d27a 100644
--- a/meta-openstack/recipes-devtools/python/python-cinder_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-cinder_git.bb
@@ -161,6 +161,8 @@ pkg_postinst_${SRCNAME}-setup () {
161PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-volume ${SRCNAME}-scheduler ${SRCNAME}-backup" 161PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-setup ${SRCNAME}-api ${SRCNAME}-volume ${SRCNAME}-scheduler ${SRCNAME}-backup"
162ALLOW_EMPTY_${SRCNAME}-setup = "1" 162ALLOW_EMPTY_${SRCNAME}-setup = "1"
163 163
164RDEPENDS_${SRCNAME}-tests += " bash"
165
164FILES_${PN} = "${libdir}/* /etc/tgt" 166FILES_${PN} = "${libdir}/* /etc/tgt"
165 167
166FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh \ 168FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh \
diff --git a/meta-openstack/recipes-devtools/python/python-glance_git.bb b/meta-openstack/recipes-devtools/python/python-glance_git.bb
index f7ae43c..b1d97c4 100644
--- a/meta-openstack/recipes-devtools/python/python-glance_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-glance_git.bb
@@ -205,7 +205,7 @@ RDEPENDS_${SRCNAME} = "${PN} \
205RDEPENDS_${SRCNAME}-api = "${SRCNAME}" 205RDEPENDS_${SRCNAME}-api = "${SRCNAME}"
206RDEPENDS_${SRCNAME}-registry = "${SRCNAME}" 206RDEPENDS_${SRCNAME}-registry = "${SRCNAME}"
207RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}" 207RDEPENDS_${SRCNAME}-setup = "postgresql sudo ${SRCNAME}"
208RDEPENDS_${SRCNAME}-tests = "python-psutil qpid-python" 208RDEPENDS_${SRCNAME}-tests = "python-psutil qpid-python bash"
209 209
210INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-registry" 210INITSCRIPT_PACKAGES = "${SRCNAME}-api ${SRCNAME}-registry"
211INITSCRIPT_NAME_${SRCNAME}-api = "glance-api" 211INITSCRIPT_NAME_${SRCNAME}-api = "glance-api"
diff --git a/meta-openstack/recipes-devtools/python/python-heat_git.bb b/meta-openstack/recipes-devtools/python/python-heat_git.bb
index dc989b5..8718147 100644
--- a/meta-openstack/recipes-devtools/python/python-heat_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-heat_git.bb
@@ -133,6 +133,9 @@ PACKAGES += "${SRCNAME}-tests ${SRCNAME}-templates ${SRCNAME}-common ${SRCNAME}-
133PACKAGES += "${SRCNAME}-setup" 133PACKAGES += "${SRCNAME}-setup"
134PACKAGES += "${SRCNAME}-cfn" 134PACKAGES += "${SRCNAME}-cfn"
135 135
136RDEPENDS_${SRCNAME}-tests += " bash"
137
138
136ALLOW_EMPTY_${SRCNAME}-setup = "1" 139ALLOW_EMPTY_${SRCNAME}-setup = "1"
137ALLOW_EMPTY_${SRCNAME}-templates = "1" 140ALLOW_EMPTY_${SRCNAME}-templates = "1"
138ALLOW_EMPTY_${SRCNAME}-cfn = "1" 141ALLOW_EMPTY_${SRCNAME}-cfn = "1"
diff --git a/meta-openstack/recipes-devtools/python/python-horizon_git.bb b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
index d7545c8..bf7f959 100644
--- a/meta-openstack/recipes-devtools/python/python-horizon_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-horizon_git.bb
@@ -133,6 +133,8 @@ do_install_append() {
133 133
134PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-apache ${SRCNAME}-standalone" 134PACKAGES += "${SRCNAME}-tests ${SRCNAME} ${SRCNAME}-apache ${SRCNAME}-standalone"
135 135
136RDEPENDS_${SRCNAME}-tests += " bash"
137
136FILES_${PN} = "${libdir}/*" 138FILES_${PN} = "${libdir}/*"
137 139
138FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 140FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
diff --git a/meta-openstack/recipes-devtools/python/python-keystone_git.bb b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
index 5db4cc0..35fdaef 100644
--- a/meta-openstack/recipes-devtools/python/python-keystone_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystone_git.bb
@@ -283,6 +283,8 @@ RDEPENDS_${PN} += " \
283 python-oauthlib \ 283 python-oauthlib \
284 " 284 "
285 285
286RDEPENDS_${SRCNAME}-tests += " bash"
287
286PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}" 288PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'OpenLDAP', 'OpenLDAP', '', d)}"
287PACKAGECONFIG[OpenLDAP] = ",,,python-ldap python-keystone-hybrid-backend" 289PACKAGECONFIG[OpenLDAP] = ",,,python-ldap python-keystone-hybrid-backend"
288 290
diff --git a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
index c001dcf..df1ed22 100644
--- a/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-keystoneclient_git.bb
@@ -52,6 +52,7 @@ FILES_${SRCNAME}-tests = "${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}/examples \
52 " 52 "
53RDEPENDS_${SRCNAME}-tests += " \ 53RDEPENDS_${SRCNAME}-tests += " \
54 python-httpretty \ 54 python-httpretty \
55 bash \
55 " 56 "
56 57
57MONITOR_CHECKS_${PN} += "\ 58MONITOR_CHECKS_${PN} += "\
diff --git a/meta-openstack/recipes-devtools/python/python-neutron_git.bb b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
index c29ccee..4166189 100644
--- a/meta-openstack/recipes-devtools/python/python-neutron_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-neutron_git.bb
@@ -204,6 +204,8 @@ PACKAGES += " \
204FILES_${PN} = "${libdir}/*" 204FILES_${PN} = "${libdir}/*"
205 205
206FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh" 206FILES_${SRCNAME}-tests = "${sysconfdir}/${SRCNAME}/run_tests.sh"
207RDEPENDS_${SRCNAME}-tests += " bash"
208
207 209
208FILES_${SRCNAME} = " \ 210FILES_${SRCNAME} = " \
209 ${bindir}/neutron-db-manage \ 211 ${bindir}/neutron-db-manage \
diff --git a/meta-openstack/recipes-devtools/python/python-nova_git.bb b/meta-openstack/recipes-devtools/python/python-nova_git.bb
index 6afe3bd..aa677ae 100644
--- a/meta-openstack/recipes-devtools/python/python-nova_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-nova_git.bb
@@ -342,6 +342,7 @@ RDEPENDS_${SRCNAME}-ec2 = "postgresql sudo ${SRCNAME}-common"
342 342
343RDEPENDS_${SRCNAME}-tests = " \ 343RDEPENDS_${SRCNAME}-tests = " \
344 python-coverage \ 344 python-coverage \
345 bash \
345 " 346 "
346 347
347INITSCRIPT_PACKAGES = "${SRCNAME}-compute ${SRCNAME}-consoleauth ${SRCNAME}-novncproxy ${SRCNAME}-spicehtml5proxy" 348INITSCRIPT_PACKAGES = "${SRCNAME}-compute ${SRCNAME}-consoleauth ${SRCNAME}-novncproxy ${SRCNAME}-spicehtml5proxy"
diff --git a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
index 9c646e4..4af6459 100644
--- a/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
+++ b/meta-openstack/recipes-devtools/python/python-pycrypto_2.6.bb
@@ -24,6 +24,8 @@ export HOST_SYS
24 24
25inherit autotools autotools-brokensep distutils 25inherit autotools autotools-brokensep distutils
26 26
27DEPENDS += " gmp"
28
27# We explicitly call distutils_do_install, since we want it to run, but 29# We explicitly call distutils_do_install, since we want it to run, but
28# *don't* want the autotools install to run, since this package doesn't 30# *don't* want the autotools install to run, since this package doesn't
29# provide a "make install" target. 31# provide a "make install" target.
diff --git a/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb b/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb
index c3d4dce..b60322f 100644
--- a/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-pyscss_1.2.1.bb
@@ -20,6 +20,7 @@ inherit setuptools
20 20
21DEPENDS += " \ 21DEPENDS += " \
22 python-pip \ 22 python-pip \
23 libpcre \
23 " 24 "
24 25
25# RDEPENDS_default: 26# RDEPENDS_default:
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
index de21ab6..03e5e40 100644
--- a/meta-openstack/recipes-devtools/python/python-swift_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -172,6 +172,7 @@ RDEPENDS_${PN} += " \
172 python-xattr \ 172 python-xattr \
173 python-pbr \ 173 python-pbr \
174 python-dnspython \ 174 python-dnspython \
175 bash \
175 " 176 "
176 177
177RDEPENDS_${SRCNAME} = "${PN}" 178RDEPENDS_${SRCNAME} = "${PN}"