summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 09:23:53 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-06-04 09:23:53 -0400
commit320dc352ec7b088d688ed6db3ad44fdff0ac5ac2 (patch)
treef4d2fc844aa3e57fb3406ce97ef344f99784a63c /meta-openstack/recipes-devtools/python
parent2fdfa2906971d76e8706c6b215d6cf9c2ecacbd8 (diff)
downloadmeta-cloud-services-320dc352ec7b088d688ed6db3ad44fdff0ac5ac2.tar.gz
cephclient: add main library/client ReST APIs
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python')
-rw-r--r--meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.4.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.4.bb b/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.4.bb
new file mode 100644
index 0000000..19f7570
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-cephclient_0.1.0.4.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "A client library in python for the Ceph REST API."
2HOMEPAGE = "https://github.com/dmsimard/python-cephclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7PR = "r0"
8
9SRCNAME = "python-cephclient"
10SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "026aefd497c0426317d951f9a6e6f251"
13SRC_URI[sha256sum] = "23ceae1f30238f7f57912422cf9baa43b7c80ed88fc14ec749986eef5f2d6007"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19# DEPENDS_default: python-pip
20
21DEPENDS += " \
22 python-pip \
23 "
24
25# RDEPENDS_default:
26RDEPENDS_${PN} += " \
27 python-lxml \
28 python-requests \
29 python-cython \
30 "