summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-29 22:58:07 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-10-01 23:10:36 -0400
commitba7ecb1f62a452baf6040f8521bcd629468241d0 (patch)
tree96b9475299246bb3c6dfa5fbdcfec782922a68ee /meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb
parent4992a62b6539201deb5b60446e81dd08803d7b36 (diff)
downloadmeta-cloud-services-ba7ecb1f62a452baf6040f8521bcd629468241d0.tar.gz
python3-ordereddict: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb b/meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb
index 46c08d0..9fa676b 100644
--- a/meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb
+++ b/meta-openstack/recipes-devtools/python/python3-ordereddict_1.1.bb
@@ -1,2 +1,21 @@
1require python-ordereddict.inc 1DESCRIPTION = "A drop-in substitute for Py2.7's new collections.OrderedDict that works in Python 2.4-2.6."
2inherit setuptools3 2HOMEPAGE = "https://pypi.python.org/pypi/ordereddict"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=7f0267460024072a9bbf135ee87a41b8"
6
7SRC_URI[md5sum] = "a0ed854ee442051b249bfad0f638bbec"
8SRC_URI[sha256sum] = "1c35b4ac206cef2d24816c89f89cf289dd3d38cf7c449bb3fab7bf6d43f01b1f"
9
10inherit setuptools3 pypi
11
12# DEPENDS_default: python-pip
13
14DEPENDS += " \
15 ${PYTHON_PN}-pip \
16 "
17
18# RDEPENDS_default:
19RDEPENDS_${PN} += " \
20 ${PYTHON_PN}-pip \
21 "