summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-09-22 10:29:46 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-27 22:44:47 -0400
commitda044b447145c3e475030fe91ae54ed2d35001d7 (patch)
tree3b9cff04a92186e12de90caab15fc1a82a057832 /meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb
parentbb37ca2e43a1c0f22e555bad82072ee70bbf014f (diff)
downloadmeta-cloud-services-da044b447145c3e475030fe91ae54ed2d35001d7.tar.gz
python3-mistralclient: Change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb b/meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb
new file mode 100644
index 0000000..dd0eb90
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-mistralclient_4.1.1.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "Python client for Mistral REST API"
2HOMEPAGE = "https://github.com/openstack/python-mistralclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7SRC_URI[sha256sum] = "b03d52ec860df292192a0face767585633e209ba9297fc71da70d42d6a76aebe"
8
9PYPI_PACKAGE = "python-mistralclient"
10
11DEPENDS += " \
12 python3-pip \
13 python3-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python3-pbr-native \
19 "
20
21RDEPENDS_${PN} +=" \
22 python3-cliff \
23 python3-pbr \
24 python3-keystoneclient \
25 python3-pyyaml \
26 python3-requests \
27 "
28
29inherit setuptools3 pypi