summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-11-23 22:42:16 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-01 16:30:52 -0500
commita0df360d24921c3792529a022e4b99ed55c2a4a4 (patch)
tree26b5a9782a1ce501e39b6568943618bd291bf424 /meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb
parentd0241986e6cc357b2eb259ad1caf70925360b8fc (diff)
downloadmeta-cloud-services-a0df360d24921c3792529a022e4b99ed55c2a4a4.tar.gz
python3-microversion-parse: Change to python3
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb b/meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb
new file mode 100644
index 0000000..43eead6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-microversion-parse_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "Simple library for parsing OpenStack microversion headers."
2HOMEPAGE = "https://github.com/openstack/microversion-parse"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7SRC_URI = "\
8 git://github.com/openstack/microversion-parse.git;branch=master \
9 "
10
11PV = "1.0.1+git${SRCPV}"
12SRCREV = "2c36df6bf33e42c379fbd8228fbe63c77b3714b1"
13S = "${WORKDIR}/git"
14
15inherit setuptools3
16
17DEPENDS += " \
18 "
19
20# Satisfy setup.py 'setup_requires'
21DEPENDS += " \
22 python3-pbr-native \
23 "
24
25RDEPENDS_${PN} += " \
26 "
27