summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2021-01-05 15:37:37 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-01-10 23:16:28 -0500
commit4cb0050c8cb74d1be150596dd6e3aac385f47a6c (patch)
tree1808e436d2d5d03cfaa6ac2a2e146390c2e05503 /meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb
parent70aaa64bf7c74f42b01534f039d07695b0dfc23c (diff)
downloadmeta-cloud-services-4cb0050c8cb74d1be150596dd6e3aac385f47a6c.tar.gz
python3-manilaclient: upgrade 2.3.0 -> 2.4.0
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb b/meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb
new file mode 100644
index 0000000..c0a5521
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-manilaclient_2.4.0.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "Python bindings to the OpenStack Manila API"
2HOMEPAGE = "https://github.com/openstack/python-manilaclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=9edbbf5857ab51214ef0e8b79069bb07"
6
7SRC_URI[sha256sum] = "e314cce0e1d2b92ff194dfa8e29bc67dd5703799a43abf7c323616ddb50d83c0"
8
9DEPENDS += " \
10 python3-pip \
11 python3-pbr \
12 "
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 python3-pbr-native \
17 "
18
19RDEPENDS_${PN} +=" \
20 python3-pbr \
21 python3-iso8601 \
22 python3-oslo.config \
23 python3-oslo.log \
24 python3-oslo.serialization \
25 python3-oslo.utils \
26 python3-prettytable \
27 python3-pycrypto \
28 python3-requests \
29 python3-simplejson \
30 python3-babel \
31 python3-six \
32 python3-keystoneclient \
33 "
34
35PYPI_PACKAGE = "python-manilaclient"
36
37inherit setuptools3 pypi