summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2021-01-05 15:37:25 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2021-01-10 23:16:28 -0500
commit85210cac8e53d3a03c5d44d28fc8d8c67ef16978 (patch)
tree18940ab8a1c0446f5fcc49fb374f829a5dbe3076 /meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb
parent4cb0050c8cb74d1be150596dd6e3aac385f47a6c (diff)
downloadmeta-cloud-services-85210cac8e53d3a03c5d44d28fc8d8c67ef16978.tar.gz
python3-magnumclient: upgrade 3.2.1 -> 3.3.0
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb b/meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb
new file mode 100644
index 0000000..9914f4c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-magnumclient_3.3.0.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Python client for containers service"
2HOMEPAGE = "https://github.com/openstack/python-magnumclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7SRC_URI[sha256sum] = "9734fbaa571fe11f252835878999efe02d4200ca9a5b1d9fe691fd5f4ec81f3b"
8
9DEPENDS += " \
10 python3-pip \
11 python3-pbr \
12 "
13
14# Satisfy setup.py 'setup_requires'
15DEPENDS += " \
16 python3-pbr-native \
17 "
18
19RDEPENDS_${PN} +=" \
20 python3-pbr \
21 python3-babel \
22 python3-oslo.config \
23 python3-oslo.i18n \
24 python3-oslo.serialization \
25 python3-oslo.utils \
26 python3-iso8601 \
27 python3-requests \
28 python3-keystoneclient \
29 python3-pyyaml \
30 python3-stevedore \
31 python3-six \
32 "
33
34PYPI_PACKAGE = "python-magnumclient"
35
36inherit setuptools3 pypi