summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-09-19 05:20:38 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-09-21 17:34:21 -0400
commit9377b94ede114001786331468bdde78ae215018a (patch)
treedc810caa9270758f5d7a09706a0eadf35ed7dba3 /meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb
parent261526041d2daea7705589202665fbd42a64bf2e (diff)
downloadmeta-cloud-services-9377b94ede114001786331468bdde78ae215018a.tar.gz
python3-jsonpath-rw-ext: Change to python3
Because python2 is no longer maintained, bb file is changed to python3 version. Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb b/meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb
new file mode 100644
index 0000000..a4517a6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-jsonpath-rw-ext_1.2.2.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Extensions for JSONPath RW"
2HOMEPAGE = "https://github.com/sileht/python-jsonpath-rw-ext"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8SRC_URI[sha256sum] = "a9e44e803b6d87d135b09d1e5af0db4d4cf97ba62711a80aa51c8c721980a994"
9
10inherit pypi setuptools3
11
12DEPENDS += " \
13 python3-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 python3-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 python3-pbr \
23 python3-babel \
24 python3-jsonpath-rw \
25 python3-six \
26 python3-ply \
27 "
28