summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-06-15 11:07:50 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-06-16 20:34:45 -0400
commit044488d89ee42c770a25f292a0f6fb40c885f821 (patch)
tree8430a5c22da37764010da0cda809e1aa52fcbcaa /meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb
parentf7dfa20cb76157b9a751843e20045261d9ba42a7 (diff)
downloadmeta-cloud-services-044488d89ee42c770a25f292a0f6fb40c885f821.tar.gz
python3-futurist: Change python to python3
upgrade 1.10.0 -> 2.2.0 python-futures is only for Python 2, so remove it. Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb b/meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb
new file mode 100644
index 0000000..4788fb2
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-futurist_2.2.0.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Useful additions to futures, from the future"
2HOMEPAGE = "https://pypi.python.org/pypi/futurist"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "708ae19b7e3bef70b47166da1e72392c"
8SRC_URI[sha256sum] = "3601ea64e3423b169683cffff58939ecee5cd5268834b20bf2da071c2563a43c"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 python3-pip \
14 python3-pbr-native \
15 "
16
17RDEPENDS_${PN} += " \
18 python3-pbr \
19 python3-six \
20 python3-monotonic \
21 python3-contextlib2 \
22 python3-prettytable \
23 "
24