summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-11-03 15:29:13 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-11-03 16:34:15 -0500
commit8d9a3bf7eaebe5556bdaf536e2b3f3bf37b0a811 (patch)
tree31b865eeb384af2adc0a647acf980c627a7f9ff6 /meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb
parent6ae911de0a0497c50d3beca874bfefd9ae9b8679 (diff)
downloadmeta-cloud-services-8d9a3bf7eaebe5556bdaf536e2b3f3bf37b0a811.tar.gz
python3-flake8: upgrade 3.8.3 -> 3.8.4
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb b/meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb
new file mode 100644
index 0000000..cc860c4
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-flake8_3.8.4.bb
@@ -0,0 +1,18 @@
1DESCRIPTION = "The modular source code checker: pep8, pyflakes and co"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=75b26781f1adf1aa310bda6098937878"
6
7SRC_URI[md5sum] = "6ab0ad6630b6917fafabded7f80344b4"
8SRC_URI[sha256sum] = "aadae8761ec651813c24be05c6f7b4680857ef6afaae4651a4eccaef97ce6c3b"
9
10inherit setuptools3 pypi
11
12RDEPENDS_${PN} += "python3-prettytable \
13 python3-cmd2 \
14 python3-pyparsing \
15 python3-mccabe \
16 python3-pep8 \
17 python3-logging \
18 python3-pyflakes"