summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-07-17 03:40:41 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-20 14:50:08 -0400
commit3dfbf74c2b1b7f1c4d50c8efc8bd625d95145dc9 (patch)
tree23405d50c805a0a9ee82bb04b86ce1ad32bc1776 /meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb
parent9390e4ff9f34bdd7ce396b45454e95d9d318cfc3 (diff)
downloadmeta-cloud-services-3dfbf74c2b1b7f1c4d50c8efc8bd625d95145dc9.tar.gz
python3-debtcollector: upgrade 1.22.0 -> 2.1.0
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb b/meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb
new file mode 100644
index 0000000..fbf4626
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-debtcollector_2.1.0.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "A collection of Python deprecation patterns and strategies that help you collect your technical debt in a non-destructive manner."
2HOMEPAGE = "http://docs.openstack.org/developer/debtcollector/"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7SRC_URI[md5sum] = "9a1014f18abbc565b8e149fd70048c22"
8SRC_URI[sha256sum] = "a25fc6215560d81cb9f2a0b58d6c834f2a24010987027bde169599e138a205af"
9
10inherit setuptools3 pypi
11
12DEPENDS += " \
13 ${PYTHON_PN}-pip \
14 ${PYTHON_PN}-pbr \
15 "
16
17# Satisfy setup.py 'setup_requires'
18DEPENDS += " \
19 ${PYTHON_PN}-pbr-native \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 ${PYTHON_PN}-pbr \
25 ${PYTHON_PN}-wrapt \
26 ${PYTHON_PN}-six \
27 "