summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@cn.fujitsu.com>2020-12-08 13:00:24 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-12-10 15:59:16 -0500
commit79952a42015b3018eede9eb2d051b1e2defd18e2 (patch)
tree002c3f89a663b0fd6f2ef0d3af7e764d3f8b9479 /meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb
parent5a5667c7a0512f13886ba56fca1b6774f70d2afe (diff)
downloadmeta-cloud-services-79952a42015b3018eede9eb2d051b1e2defd18e2.tar.gz
python3-cliff: upgrade 3.4.0 -> 3.5.0
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb b/meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb
new file mode 100644
index 0000000..5ba0894
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python3-cliff_3.5.0.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Command Line Interface Formulation Framework"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[md5sum] = "45a7f6f6e9e392ad8dbf79f802930047"
8SRC_URI[sha256sum] = "5bfb684b5fcdff0afaaccd1298a376c0e62e644c46b7e9abc034595b41fe1759"
9
10inherit setuptools3 pypi
11
12DEPENDS += "\
13 ${PYTHON_PN}-pbr \
14 "
15
16# Satisfy setup.py 'setup_requires'
17DEPENDS += " \
18 ${PYTHON_PN}-pbr-native \
19 "
20
21RDEPENDS_${PN} += " \
22 ${PYTHON_PN}-cmd2 \
23 ${PYTHON_PN}-pbr \
24 ${PYTHON_PN}-pyparsing \
25 ${PYTHON_PN}-prettytable \
26 ${PYTHON_PN}-six \
27 ${PYTHON_PN}-stevedore \
28 ${PYTHON_PN}-pyyaml \
29"
30
31CLEANBROKEN = "1"