summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 14:32:30 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:38:27 -0500
commit7063d4b65c27585a9ae282f75e6cadc8ee395273 (patch)
treef75bcd9027d28320e3c337c1e5f6017300dca165 /meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb
parentb89b484046975c026a5770fe397694a245e1f176 (diff)
downloadmeta-cloud-services-7063d4b65c27585a9ae282f75e6cadc8ee395273.tar.gz
python-xstatic-*: uprev to required versions
The python-horizon requires specific versions of the various python-xstatic-* per its requirements.txt file. Being 'xtatic' packages these have no additional dependencies so the uprevs are mostly straitforward version updates with a check that the license hasn't changed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb b/meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb
new file mode 100644
index 0000000..b68fb62
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-jasmine_2.4.1.1.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "Jasmine JavaScript library packaged for setuptools "
2HOMEPAGE = "https://pypi.python.org/pypi/XStatic-Jasmine"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
6
7PYPI_PACKAGE = "XStatic-Jasmine"
8
9SRC_URI[md5sum] = "9378ce965dfcb4ddb64855cc717d4ec8"
10SRC_URI[sha256sum] = "d1e8bf3c0e1cf683cc2c0aad95f197e9e51ea747fb91291445223a2b7dbc4740"
11
12inherit setuptools pypi
13
14# DEPENDS_default: python-pip
15
16DEPENDS += " \
17 python-pip \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 "