summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 16:48:05 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:40:01 -0500
commit3d512115129e2cea97067d23cb72fea62b70dd39 (patch)
treed891dce76b3cfa2bcb2b4afaf04704fa862da1f6 /meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb
parentb63d5e8f9d1a6ce468d8c327fbdc6bdcff357ee2 (diff)
downloadmeta-cloud-services-3d512115129e2cea97067d23cb72fea62b70dd39.tar.gz
python-*: switch remaining pypi recipes to use the pypi class
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes using archived versions of packages we must set PYPI_SRC_URI to overwrite what the pypi class would derive. For example when the archive is a zip and not a tar.gz. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb b/meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb
index 2ad3e55..daa74bc 100644
--- a/meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-xstatic-angular-irdragndrop_1.0.2.2.bb
@@ -4,15 +4,12 @@ SECTION = "devel/python"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=9acc2dfc3a0345c175df08104bd22298" 5LIC_FILES_CHKSUM = "file://PKG-INFO;md5=9acc2dfc3a0345c175df08104bd22298"
6 6
7SRCNAME = "XStatic-Angular-IrDragNDrop" 7PYPI_PACKAGE = "XStatic-Angular-IrDragNDrop"
8SRC_URI = "http://pypi.python.org/packages/source/X/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9 8
10SRC_URI[md5sum] = "6ea8809bae94014aef699d58836dba84" 9SRC_URI[md5sum] = "6ea8809bae94014aef699d58836dba84"
11SRC_URI[sha256sum] = "5595f4a98ac8f8468f7e56dc916e10c0fc5f0197567899a75755f99fe8b5bd6d" 10SRC_URI[sha256sum] = "5595f4a98ac8f8468f7e56dc916e10c0fc5f0197567899a75755f99fe8b5bd6d"
12 11
13S = "${WORKDIR}/${SRCNAME}-${PV}" 12inherit setuptools pypi
14
15inherit setuptools
16 13
17DEPENDS += " \ 14DEPENDS += " \
18 python-pip \ 15 python-pip \