summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:21 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitd0b24c0e256ef93079c47384d0c4a297b73df57e (patch)
treeea87a1e99e710929893f763c580d7f6e64f0dabb /meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb
parent300a6abfb2d8a08f911baffef1afe0cfa8b398ca (diff)
downloadmeta-cloud-services-d0b24c0e256ef93079c47384d0c4a297b73df57e.tar.gz
python-unicodecsv: initial version
This package provides Python2's stdlib csv module replacement with unicode support. This package is required by python-cliff. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb b/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb
new file mode 100644
index 0000000..76d638a
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-unicodecsv_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Python2's stdlib csv module replacement with unicode support"
2HOMEPAGE = "https://github.com/jdunck/python-unicodecsv"
3SECTION = "devel/python"
4LICENSE = "BSD"
5
6PV = "0.14.1+git${SRCPV}"
7SRCREV = "4563e33ce322f5e2dea41e76cb33dc0e008ad341"
8
9SRCNAME = "unicodecsv"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=e71cdeaa2d2d59b225b8dfb9363fa590"
12SRC_URI = "git://github.com/jdunck/${BPN}.git"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools
17
18DEPENDS += " \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 "
24