summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-04-30 15:08:33 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-04-30 15:42:49 -0400
commit0fc2be6f8bef0f52a81294b0e80adf6c3be57630 (patch)
tree0eb20a21018f42f3f0544e166254aa60fa83c62d /meta-openstack/recipes-devtools/python/python-troveclient_git.bb
parent8383087f6a3433316bba34d4dabffa29bb8070aa (diff)
downloadmeta-cloud-services-0fc2be6f8bef0f52a81294b0e80adf6c3be57630.tar.gz
python-troveclient: introduce trove client
icehouse horizon looks for troveclient. So we introduce it (without full trove support), to keep it happy. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-troveclient_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-troveclient_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-troveclient_git.bb b/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
new file mode 100644
index 0000000..35f3320
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-troveclient_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Client Library for OpenStack Datbase service"
2HOMEPAGE = "https://github.com/openstack/python-troveclient"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PR = "r0"
8
9SRC_URI = "\
10 git://github.com/openstack/python-troveclient.git;branch=master \
11 "
12
13PV="1.0.5+git${SRCPV}"
14SRCREV="248aa8fdf801ca73834606239d3cdb3610993815"
15S = "${WORKDIR}/git"
16
17inherit setuptools
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} += " \
25 python-pbr \
26 python-prettytable \
27 python-requests \
28 python-simplejson \
29 python-babel \
30 python-six \
31 "