summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-01-09 15:15:04 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-01-12 10:38:06 -0500
commit68b387605a45383577159478958ceeba121ade6a (patch)
tree2c5d9e845ee426416e71681d27387f56d36701e7 /meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb
parent9936e2b222ec274ba17468c3c9feee920a6b6185 (diff)
downloadmeta-cloud-services-68b387605a45383577159478958ceeba121ade6a.tar.gz
python-tinyrpc: initial version
This is needed for the uprev of python-ryu. This requires new recipes for python-jsonext and python-gevent-websocket. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb b/meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb
new file mode 100644
index 0000000..28e230d
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-tinyrpc_0.6.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "A small, modular, transport and protocol neutral \
2RPC library that, among other things, supports JSON-RPC and zmq."
3HOMEPAGE = "http://github.com/mbr/tinyrpc"
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
7
8SRC_URI[md5sum] = "2663568ba3e1793da7b21003f0847fdd"
9SRC_URI[sha256sum] = "b4d64227f023f1f0736ef137bd4c901c7652563e62c7a20329222c3a0b14d84f"
10
11inherit setuptools pypi
12
13RDEPENDS_${PN} += " \
14 python-six \
15 python-gevent \
16 python-requests \
17 python-websocket-client \
18 python-jsonext \
19 python-gevent-websocket \
20 python-werkzeug \
21 python-pyzmq \
22 "