summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
diff options
context:
space:
mode:
authorHuang Qiyu <huangqy.fnst@cn.fujitsu.com>2018-03-30 17:28:37 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-03 23:24:54 -0400
commit829a641319ecd7f3b8407adfae26ce126cdd1b37 (patch)
treee85715d2f1aa478b3c0c1eb49879a7c5dc08d18b /meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
parent8aa49d991123a954b404686cead6b58dc6de9242 (diff)
downloadmeta-cloud-services-829a641319ecd7f3b8407adfae26ce126cdd1b37.tar.gz
python-testtools: 2.2.0 -> 2.3.0
Upgrade python-testtools from 2.2.0 to 2.3.0. Signed-off-by: Huang Qiyu <huangqy.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb b/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
new file mode 100644
index 0000000..bbf1d01
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Extensions to the Python standard library unit testing framework"
2HOMEPAGE = "https://pypi.python.org/pypi/testtools/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
6
7SRC_URI[md5sum] = "0f0feb915497816cb99e39437494217e"
8SRC_URI[sha256sum] = "5827ec6cf8233e0f29f51025addd713ca010061204fdea77484a2934690a0559"
9
10inherit setuptools pypi
11DEPENDS += " \
12 python-pbr \
13 "
14
15# Satisfy setup.py 'setup_requires'
16DEPENDS += " \
17 python-pbr-native \
18 "
19
20RDEPENDS_${PN} += "\
21 python-extras \
22 python-pbr \
23 "