summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2019-09-09 15:07:30 +0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2019-09-09 13:34:54 -0400
commit3a87c591ff5a5b669bfeb73c6d184d1d2e1d6c2d (patch)
treea170278f590fc9111185ada4b13ef7184ed70732 /meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
parent656768859b4f429884d6af60a7297335b1729628 (diff)
downloadmeta-cloud-services-3a87c591ff5a5b669bfeb73c6d184d1d2e1d6c2d.tar.gz
python-testtools: Add python3 version
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb25
1 files changed, 2 insertions, 23 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb b/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
index bbf1d01..56ff9de 100644
--- a/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testtools_2.3.0.bb
@@ -1,23 +1,2 @@
1DESCRIPTION = "Extensions to the Python standard library unit testing framework" 1inherit setuptools
2HOMEPAGE = "https://pypi.python.org/pypi/testtools/" 2require python-testtools.inc
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
6
7SRC_URI[md5sum] = "0f0feb915497816cb99e39437494217e"
8SRC_URI[sha256sum] = "5827ec6cf8233e0f29f51025addd713ca010061204fdea77484a2934690a0559"
9
10inherit setuptools pypi
11DEPENDS += " \
12 python-pbr \
13 "
14
15# Satisfy setup.py 'setup_requires'
16DEPENDS += " \
17 python-pbr-native \
18 "
19
20RDEPENDS_${PN} += "\
21 python-extras \
22 python-pbr \
23 "