summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-17 14:34:51 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-17 14:37:44 -0500
commit39087ecc8581227a7c469260485229f71511215d (patch)
tree93a309c6a945fc220bbe461bc9daea1be83370bf /meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
parent844f0ad2aa79bf478f30a77dbbbf626471d7820f (diff)
downloadmeta-cloud-services-39087ecc8581227a7c469260485229f71511215d.tar.gz
python: satisfy setup.py 'setup_requires'
Python setuptools will attempt to satisfy the packages defined as 'setup_requires' in setup.py by first looking for the package availability locally and ultimately by downloading it from PyPI. This is actually a huge security hole and packages should move to using pip instead, but this is another story that the upstream packages have to address. This also disregards BB_NO_NETWORK and may prove to introduce host contamination. The best approach is to ensure we have the -native version of the 'setup_requires' packages present such that setup.py will not attempt to complete the download from PyPI. Make 'pbr' -native available and for packages which we have identified as having 'setup_requires' include 'pbr' add the necessary python-pbr-native DEPENDS. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb b/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
index 994b6b5..a777b31 100644
--- a/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
+++ b/meta-openstack/recipes-devtools/python/python-testscenarios_0.5.0.bb
@@ -20,6 +20,11 @@ DEPENDS += "\
20 python-pbr \ 20 python-pbr \
21 " 21 "
22 22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
23RDEPENDS_${PN} += "\ 28RDEPENDS_${PN} += "\
24 python-testtools \ 29 python-testtools \
25 python-pbr \ 30 python-pbr \