summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-16 14:20:42 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-17 11:10:29 -0500
commit6525fbca288d5d06be696447ad7f457af01f080d (patch)
tree8535966e6cdffdfe6ea0258bed8c855dffc28aab /meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
parented81a9b98b545183b0a0ff24d09841bc622fe7f4 (diff)
downloadmeta-cloud-services-6525fbca288d5d06be696447ad7f457af01f080d.tar.gz
python-*: switch remaining (https) pypi recipes to use the pypi class
The original commit to switch pypi recipes to use the pypi.bbclass only addressed the urgent need to get the recipes using "http" converted. This change is the same but converts the remaining pypi recipes which were already uing "https". Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes which use 'zip' or 'bz2' extensions we need to set PYPI_PACKAGE_EXT. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb b/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
index edb6fe8..79be868 100644
--- a/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
+++ b/meta-openstack/recipes-devtools/python/python-testrepository_0.0.20.bb
@@ -4,17 +4,10 @@ SECTION = "devel/python"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=f19071a777e237c55ec3ab83284b31b8" 5LIC_FILES_CHKSUM = "file://COPYING;md5=f19071a777e237c55ec3ab83284b31b8"
6 6
7SRCNAME = "testrepository"
8
9SRC_URI = "https://pypi.python.org/packages/source/t/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "f648b0aceeca4fcd5f8a62eeedea289b" 7SRC_URI[md5sum] = "f648b0aceeca4fcd5f8a62eeedea289b"
12SRC_URI[sha256sum] = "752449bc98c20253ec4611c40564aea93d435a5bf3ff672208e01cc10e5858eb" 8SRC_URI[sha256sum] = "752449bc98c20253ec4611c40564aea93d435a5bf3ff672208e01cc10e5858eb"
13 9
14 10inherit setuptools pypi
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18 11
19RDEPENDS_${PN} += "python-subunit \ 12RDEPENDS_${PN} += "python-subunit \
20 python-extras \ 13 python-extras \