summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-swift_git.bb
diff options
context:
space:
mode:
authorAndy Ning <andy.ning@windriver.com>2014-07-16 11:37:37 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2014-07-30 00:50:59 -0400
commit0aec82d70fa032bfe616ea5058d504f860e241f8 (patch)
treecd88ce4f6c7ac88308b85d1ce66941877978cc51 /meta-openstack/recipes-devtools/python/python-swift_git.bb
parentceecd0d46de35111f4c3c1e65176e09cb2117ecb (diff)
downloadmeta-cloud-services-0aec82d70fa032bfe616ea5058d504f860e241f8.tar.gz
Keystone: package service/user additions
Instead of creating tenant/user/role and service/endpoint for all openstack services in keystone postinstall, now each of the services creates its own keystone identities by queueing them up in its postinstall to a file /etc/keystone/service-user-setup. service-user-setup script, when run as the last postinstall, calls identity.sh with keystone identity parameters to create necessary identities for the services. Signed-off-by: Andy Ning <andy.ning@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-swift_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
index 7bab0bd..16f99f7 100644
--- a/meta-openstack/recipes-devtools/python/python-swift_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -29,6 +29,25 @@ inherit setuptools python-dir update-rc.d hosts identity
29# filesystem of must support xattrs. e.g ext4 29# filesystem of must support xattrs. e.g ext4
30SWIFT_BACKING_FILE_SIZE ?= "2G" 30SWIFT_BACKING_FILE_SIZE ?= "2G"
31 31
32SERVICECREATE_PACKAGES = "${SRCNAME}-setup"
33KEYSTONE_HOST="${CONTROLLER_IP}"
34
35# USERCREATE_PARAM and SERVICECREATE_PARAM contain the list of parameters to be set.
36# If the flag for a parameter in the list is not set here, the default value will be given to that parameter.
37# Parameters not in the list will be set to empty.
38
39USERCREATE_PARAM_${SRCNAME}-setup = "name pass tenant role email"
40SERVICECREATE_PARAM_${SRCNAME}-setup = "name type description region publicurl adminurl internalurl"
41python () {
42 flags = {'type':'object-store',\
43 'description':'OpenStack object-store',\
44 'publicurl':"'http://${KEYSTONE_HOST}:8888/v1/AUTH_\$(tenant_id)s'",\
45 'adminurl':"'http://${KEYSTONE_HOST}:8888/v1'",\
46 'internalurl':"'http://${KEYSTONE_HOST}:8888/v1/AUTH_\$(tenant_id)s'"}
47
48 d.setVarFlags("SERVICECREATE_PARAM_%s-setup" % d.getVar('SRCNAME',True), flags)
49}
50
32do_install_append() { 51do_install_append() {
33 SWIFT_CONF_DIR=${D}${sysconfdir}/swift 52 SWIFT_CONF_DIR=${D}${sysconfdir}/swift
34 53