summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-swift_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-10-31 01:30:55 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-11-25 15:25:35 -0500
commit01ac9544e0a645f80f0c3aea327bf3ee8d02fff9 (patch)
treeae36cebdb8571699ab08bba9b89300f01865de38 /meta-openstack/recipes-devtools/python/python-swift_git.bb
parent2290ee09ef3c2cd8aaf7fe3dc40bf22eb842b3f4 (diff)
downloadmeta-cloud-services-01ac9544e0a645f80f0c3aea327bf3ee8d02fff9.tar.gz
swift: uprev to havana release
Upreving the swift component to the havana release. At the same time, we switch to building from git. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-swift_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-swift_git.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-swift_git.bb b/meta-openstack/recipes-devtools/python/python-swift_git.bb
new file mode 100644
index 0000000..971c77c
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-swift_git.bb
@@ -0,0 +1,50 @@
1DESCRIPTION = "Highly available, distributed, eventually consistent object/blob store."
2HOMEPAGE = "https://launchpad.net/swift"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7PR = "r0"
8SRCNAME = "swift"
9
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/havana \
11"
12
13SRCREV="9b521fe800ed3984169d37e9772674867745fede"
14PV="2013.2+git${SRCPV}"
15S = "${WORKDIR}/git"
16
17inherit setuptools
18
19do_install_append() {
20 SWIFT_CONF_DIR=${D}${sysconfdir}/swift
21
22 install -d ${SWIFT_CONF_DIR}
23
24 install -m 600 ${S}/etc/swift.conf-sample ${SWIFT_CONF_DIR}/swift.conf
25 install -m 600 ${S}/etc/proxy-server.conf-sample ${SWIFT_CONF_DIR}/proxy-server.conf
26 install -m 600 ${S}/etc/account-server.conf-sample ${SWIFT_CONF_DIR}/account-server.conf
27 install -m 600 ${S}/etc/container-server.conf-sample ${SWIFT_CONF_DIR}/container-server.conf
28 install -m 600 ${S}/etc/object-server.conf-sample ${SWIFT_CONF_DIR}/object-server.conf
29}
30
31PACKAGES += "${SRCNAME}"
32
33FILES_${PN} = "${libdir}/*\
34"
35
36FILES_${SRCNAME} = "${bindir}/* \
37 ${sysconfdir}/${SRCNAME}/* \
38"
39
40RDEPENDS_${PN} += " \
41 python-eventlet \
42 python-greenlet \
43 python-pastedeploy \
44 python-simplejson \
45 python-swiftclient \
46 python-netifaces \
47 python-xattr \
48 "
49
50RDEPENDS_${SRCNAME} = "${PN}" \ No newline at end of file