summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-13 16:48:05 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-14 12:40:01 -0500
commit3d512115129e2cea97067d23cb72fea62b70dd39 (patch)
treed891dce76b3cfa2bcb2b4afaf04704fa862da1f6 /meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
parentb63d5e8f9d1a6ce468d8c327fbdc6bdcff357ee2 (diff)
downloadmeta-cloud-services-3d512115129e2cea97067d23cb72fea62b70dd39.tar.gz
python-*: switch remaining pypi recipes to use the pypi class
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http which is apparently going to be disabled soon. In most cases we are able to drop SRC_URI, however, for some recipes using archived versions of packages we must set PYPI_SRC_URI to overwrite what the pypi class would derive. For example when the archive is a zip and not a tar.gz. In all cases we can drop the defining of 'S' and 'PR' as the pypi class and the PR server will set these correctly. In most cases we can drop SRCNAME. Where needed we instead set PYPI_PACKAGE to overwrite the derived name that the pypi class would otherwise calculate. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb b/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
index 746d646..a038abb 100644
--- a/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
+++ b/meta-openstack/recipes-devtools/python/python-semantic-version_2.4.2.bb
@@ -4,18 +4,15 @@ SECTION = "devel/python"
4LICENSE = "BSD" 4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a7dcaa0740d59f8f13ef05a3d0ed7313" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=a7dcaa0740d59f8f13ef05a3d0ed7313"
6 6
7SRCNAME = "semantic_version" 7PYPI_PACKAGE = "semantic_version"
8SRC_URI = "http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
9 8
10SRC_URI[md5sum] = "fd7d5ade76e78d8540b9a4044496a57c" 9SRC_URI[md5sum] = "fd7d5ade76e78d8540b9a4044496a57c"
11SRC_URI[sha256sum] = "7e8b7fa74a3bc9b6e90b15b83b9bc2377c78eaeae3447516425f475d5d6932d2" 10SRC_URI[sha256sum] = "7e8b7fa74a3bc9b6e90b15b83b9bc2377c78eaeae3447516425f475d5d6932d2"
12 11
13S = "${WORKDIR}/${SRCNAME}-${PV}"
14
15#export BUILD_SYS 12#export BUILD_SYS
16#export HOST_SYS 13#export HOST_SYS
17 14
18inherit setuptools 15inherit setuptools pypi
19 16
20# DEPENDS_default: python-pip 17# DEPENDS_default: python-pip
21 18