summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ryu_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:27 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit27dbf43410e1740317990d82a5db7f34205f92a8 (patch)
treeafa9feb4b65616945a9f9d169e773f69ebeede96 /meta-openstack/recipes-devtools/python/python-ryu_git.bb
parentea5eb7a0243bea75ef479f46ed4b6384a4c9d062 (diff)
downloadmeta-cloud-services-27dbf43410e1740317990d82a5db7f34205f92a8.tar.gz
python-ryu: initial version
This package provides Ryu component-based software defined networking framework. This package is required by neutron. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ryu_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ryu_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ryu_git.bb b/meta-openstack/recipes-devtools/python/python-ryu_git.bb
new file mode 100644
index 0000000..adf7957
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-ryu_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "Ryu component-based software defined networking framework"
2HOMEPAGE = "http://osrg.github.io/ryu/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7PV = "3.27+git${SRCPV}"
8SRCREV = "0aefad7048079656cdaad138be58f017e6b4f1ce"
9
10SRCNAME = "ryu"
11SRC_URI = "git://github.com/osrg/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17FILES_${PN} += "${datadir}/etc/${SRCNAME}/*"
18
19DEPENDS += " \
20 python-pip \
21 python-pbr \
22 "
23
24RDEPENDS_${PN} += " \
25 python-eventlet \
26 python-msgpack \
27 python-netaddr \
28 python-oslo.config \
29 python-routes \
30 python-six \
31 python-webob \
32 "