summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-routes_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:06 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit3dd375570e0c1bc3a94d1d821946c511b17b1382 (patch)
tree02df0ad801228de173b3ca88ac5862c7e5d9d3f0 /meta-openstack/recipes-devtools/python/python-routes_git.bb
parentac446f3bc8a6df622f3551952f055064847f6f0e (diff)
downloadmeta-cloud-services-3dd375570e0c1bc3a94d1d821946c511b17b1382.tar.gz
python-*: uprev to versions required for liberty
This is a collection of recipe uprevs that bring various packages up to the version required to support the liberty release. These uprevs are mostly trivial with the expected SRC_URI and CHECKSUM updates along with updates to the list of dependencies. Where possible recipes have been updated to use git to facilitate future uprevs. For python-futures we need to add a PREFERRED_VERSION to ensure the git version will take precedence over a versioned recipe found in another layer. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-routes_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-routes_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-routes_git.bb b/meta-openstack/recipes-devtools/python/python-routes_git.bb
new file mode 100644
index 0000000..814339b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-routes_git.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "A Python re-implementation of the Rails routes system."
2HOMEPAGE = "http://routes.groovie.org"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=aa6285dc7b7c93b3905bb2757f33eb62"
6
7PV = "1.13+git${SRCPV}"
8SRCREV = "467501d5fcfa265b3dfae615e7f0dcda8ce79d4e"
9
10SRCNAME = "Routes"
11SRC_URI = "git://github.com/bbangert/routes.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17RDEPENDS_${PN} += "python-repoze.lru"