summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:10 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commitd957581082e8bb178fef2ee2e150c7723f5432e0 (patch)
treef71675eb47a49ddbad61c90e1e5b61d43bce6f1e /meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb
parent84ff9a5d6ff548754936c1b5bf0fc5a3adf32a1a (diff)
downloadmeta-cloud-services-d957581082e8bb178fef2ee2e150c7723f5432e0.tar.gz
python-repoze.who: initial version
This package provides an identification and authentication framework for WSGI. This package is required by python-pysaml2. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb b/meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb
new file mode 100644
index 0000000..35e5821
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-repoze.who_2.2.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "An identification and authentication framework for WSGI"
2HOMEPAGE = "http://repoze.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-derived"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2c33cdbc6bc9ae6e5d64152fdb754292"
6
7
8SRCNAME = "repoze.who"
9SRC_URI = "http://pypi.python.org/packages/source/r/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "c677ac4d4a32b6f6880a8f9cf20adffb"
12SRC_URI[sha256sum] = "322629ec7c779dce4700e8f3ba531002b724d2429178c1cbb0dc169255dc9a8b"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18# DEPENDS_default: python-pip
19
20DEPENDS += " \
21 python-pip \
22 "
23
24# RDEPENDS_default:
25RDEPENDS_${PN} += " \
26 python-pip \
27 python-zopeinterface \
28 "