summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-04-04 16:02:52 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-04-09 10:48:37 -0400
commita112d86e7472251ac6518c2b7aed5efb8222582d (patch)
tree5175172d4aae89844cb6355cf63d70f760c847b5 /meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
parenta539eeb162586183d027b4709581fe9bab213dad (diff)
downloadmeta-cloud-services-a112d86e7472251ac6518c2b7aed5efb8222582d.tar.gz
python-pypowervm: initial version (v1.1.10)
Required by the stable/pike version of python-nova. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb b/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
new file mode 100644
index 0000000..a646c47
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pypowervm_1.1.10.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Python binding for the PowerVM REST API"
2HOMEPAGE = "https://pypi.python.org/pypi/pypowervm"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRC_URI[md5sum] = "54e4dfaa569350254b0a0f4c19686ded"
8SRC_URI[sha256sum] = "ab27d4efb59105555b6c9b1fe7792fd895ad9ca893058c39bba4106d6a0ad986"
9
10inherit setuptools pypi
11
12RDEPENDS_${PN} += " \
13 python-lxml \
14 python-oslo.concurrency \
15 python-oslo.context \
16 python-oslo.i18n \
17 python-oslo.log \
18 python-oslo.utils \
19 python-pbr \
20 python-pyasn1-modules \
21 python-pyasn1 \
22 python-pytz \
23 python-requests \
24 python-six \
25 python-futures \
26 python-taskflow \
27 python-networkx \
28 "