summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:22:39 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-12-11 02:22:39 -0500
commit8d106c85a99ef8450e098e627428e37386ac6b10 (patch)
treec7db8e0c4a4236d0edcaf763e80ea69daed5e8aa /meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb
parenta0c214734ab594d018354c5262b653aeb428a20b (diff)
downloadmeta-cloud-services-8d106c85a99ef8450e098e627428e37386ac6b10.tar.gz
python-flake8: introduce python-flake8 and dependencies
For full tempest test results, we require flake8 and dependencies. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb b/meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb
new file mode 100644
index 0000000..af7a7f3
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pyflakes_0.7.3.bb
@@ -0,0 +1,21 @@
1DESCRIPTION = "passive checker of Python programs"
2HOMEPAGE = "https://github.com/dreamhost/cliff"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://README.rst;md5=1815018ebbbfc8659a9df33681a0936e"
6
7PR = "r0"
8SRCNAME = "pyflakes"
9
10SRC_URI = "https://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
11
12SRC_URI[md5sum] = "ec94ac11cb110e6e72cca23c104b66b1"
13SRC_URI[sha256sum] = "dbd2c940a1030a4f811afc1a04017a44011c0cb54f8f384b66aa624097d9b5e3"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} += "python-prettytable \
20 python-cmd2 \
21 python-pyparsing" \ No newline at end of file