summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-psycopg2
diff options
context:
space:
mode:
authorMihai Prica <prica.mihai@gmail.com>2013-06-27 14:15:51 +0300
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:57 -0400
commit64c6a7a41e53b288b5cf5fcc0097421228261f07 (patch)
treeb6f85ad86ad2bc6c84302d5edde7d4622156cfaf /meta-openstack/recipes-devtools/python/python-psycopg2
parent1510c871a8e7291cd49b056db3af756c5ff296b4 (diff)
downloadmeta-cloud-services-64c6a7a41e53b288b5cf5fcc0097421228261f07.tar.gz
python-psycopg2: Renamed patch
Added the reason for why it is necessary and the UpstreamStatus to the patch. Signed-off-by: Mihai Prica <prica.mihai@gmail.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-psycopg2')
-rw-r--r--meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch (renamed from meta-openstack/recipes-devtools/python/python-psycopg2/quick-fix.patch)11
1 files changed, 7 insertions, 4 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-psycopg2/quick-fix.patch b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
index 0fa6e5e..104d692 100644
--- a/meta-openstack/recipes-devtools/python/python-psycopg2/quick-fix.patch
+++ b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
@@ -1,17 +1,20 @@
1Upstream-status: Inappropriate [embedded specific]
2
3The package uses the pg_config command to detect the libdir and includedir path.
4Commented the lines because the command is not available at buildtime and the
5package succesfully build without them.
6
1Index: psycopg2-2.5/setup.py 7Index: psycopg2-2.5/setup.py
2=================================================================== 8===================================================================
3--- psycopg2-2.5.orig/setup.py 9--- psycopg2-2.5.orig/setup.py
4+++ psycopg2-2.5/setup.py 10+++ psycopg2-2.5/setup.py
5@@ -377,9 +377,9 @@ class psycopg_build_ext(build_ext): 11@@ -377,9 +377,6 @@ class psycopg_build_ext(build_ext):
6 self.libraries.append("pq") 12 self.libraries.append("pq")
7 13
8 try: 14 try:
9- self.library_dirs.append(pg_config_helper.query("libdir")) 15- self.library_dirs.append(pg_config_helper.query("libdir"))
10- self.include_dirs.append(pg_config_helper.query("includedir")) 16- self.include_dirs.append(pg_config_helper.query("includedir"))
11- self.include_dirs.append(pg_config_helper.query("includedir-server")) 17- self.include_dirs.append(pg_config_helper.query("includedir-server"))
12+ #self.library_dirs.append(pg_config_helper.query("libdir"))
13+ #self.include_dirs.append(pg_config_helper.query("includedir"))
14+ #self.include_dirs.append(pg_config_helper.query("includedir-server"))
15 try: 18 try:
16 # Here we take a conservative approach: we suppose that 19 # Here we take a conservative approach: we suppose that
17 # *at least* PostgreSQL 7.4 is available (this is the only 20 # *at least* PostgreSQL 7.4 is available (this is the only