summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-psycopg2
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-08-10 00:41:54 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-08-28 18:41:59 -0400
commit13312e07349cbd3ef67e50e6bce8b1002bab4566 (patch)
tree91f6c2363233b74610d9a748cd067d79da513196 /meta-openstack/recipes-devtools/python/python-psycopg2
parentd957c53425a7472f2d28a863ab6eae13174cf9da (diff)
downloadmeta-cloud-services-13312e07349cbd3ef67e50e6bce8b1002bab4566.tar.gz
python-psycopg2: remove references to pg-config
pg-config is not provided as a native tool, so if called, the host version will be found. Since the values that are typically returned by pg-config can be determined in our build environment, we can safely remove the calls completely. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-psycopg2')
-rw-r--r--meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
index 104d692..6b72ef7 100644
--- a/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
+++ b/meta-openstack/recipes-devtools/python/python-psycopg2/remove-pg-config.patch
@@ -8,7 +8,7 @@ Index: psycopg2-2.5/setup.py
8=================================================================== 8===================================================================
9--- psycopg2-2.5.orig/setup.py 9--- psycopg2-2.5.orig/setup.py
10+++ psycopg2-2.5/setup.py 10+++ psycopg2-2.5/setup.py
11@@ -377,9 +377,6 @@ class psycopg_build_ext(build_ext): 11@@ -377,9 +377,6 @@
12 self.libraries.append("pq") 12 self.libraries.append("pq")
13 13
14 try: 14 try:
@@ -18,3 +18,16 @@ Index: psycopg2-2.5/setup.py
18 try: 18 try:
19 # Here we take a conservative approach: we suppose that 19 # Here we take a conservative approach: we suppose that
20 # *at least* PostgreSQL 7.4 is available (this is the only 20 # *at least* PostgreSQL 7.4 is available (this is the only
21Index: psycopg2-2.5/setup.cfg
22===================================================================
23--- psycopg2-2.5.orig/setup.cfg
24+++ psycopg2-2.5/setup.cfg
25@@ -11,7 +11,7 @@
26 # build psycopg2. If pg_config is not in the path or is installed under a
27 # different name uncomment the following option and set it to the pg_config
28 # full path.
29-#pg_config=
30+pg_config="/bin/true"
31
32 # Set to 1 to use Python datetime objects for default date/time representation.
33 use_pydatetime=1