summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-01-17 14:34:51 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-01-17 14:37:44 -0500
commit39087ecc8581227a7c469260485229f71511215d (patch)
tree93a309c6a945fc220bbe461bc9daea1be83370bf /meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
parent844f0ad2aa79bf478f30a77dbbbf626471d7820f (diff)
downloadmeta-cloud-services-39087ecc8581227a7c469260485229f71511215d.tar.gz
python: satisfy setup.py 'setup_requires'
Python setuptools will attempt to satisfy the packages defined as 'setup_requires' in setup.py by first looking for the package availability locally and ultimately by downloading it from PyPI. This is actually a huge security hole and packages should move to using pip instead, but this is another story that the upstream packages have to address. This also disregards BB_NO_NETWORK and may prove to introduce host contamination. The best approach is to ensure we have the -native version of the 'setup_requires' packages present such that setup.py will not attempt to complete the download from PyPI. Make 'pbr' -native available and for packages which we have identified as having 'setup_requires' include 'pbr' add the necessary python-pbr-native DEPENDS. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb b/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
index fdf80b3..2018a1b 100644
--- a/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
+++ b/meta-openstack/recipes-devtools/python/python-pbr_1.8.1.bb
@@ -21,6 +21,10 @@ DEPENDS += " \
21 python-pip \ 21 python-pip \
22 " 22 "
23 23
24DEPENDS_class-native += ""
25
24# RDEPENDS_default: 26# RDEPENDS_default:
25RDEPENDS_${PN} += " \ 27RDEPENDS_${PN} += " \
26 " 28 "
29
30BBCLASSEXTEND = "native"