summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-05-13 15:24:33 +0800
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-05-13 16:50:29 -0400
commit73a905b7515f3dfcb0d235cb56ef9452c16d1d3e (patch)
tree5b71183acb74bb85622bb45bebfa23502985bd62 /meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
parent0ccf2330790448d6210f9bcb5f22d164200e954d (diff)
downloadmeta-cloud-services-73a905b7515f3dfcb0d235cb56ef9452c16d1d3e.tar.gz
python-pathlib: add new recipe
It's required by python-django-pyscss. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb b/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
new file mode 100644
index 0000000..ae26da1
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-pathlib_1.0.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Object-oriented filesystem paths"
2DESCRIPTION = "pathlib offers a set of classes to handle filesystem paths. \
3It offers the following advantages over using string objects: \
4- No more cumbersome use of os and os.path functions. \
5- Embodies the semantics of different path types. \
6- Well-defined semantics, eliminating any warts or ambiguities. \
7"
8HOMEPAGE = "https://pypi.python.org/pypi/pathlib"
9SECTION = "devel/python"
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b6557c860f0fc867aeab30afd649753"
12
13
14SRCNAME = "pathlib"
15SRC_URI = "http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
16
17SRC_URI[md5sum] = "5099ed48be9b1ee29b31c82819240537"
18SRC_URI[sha256sum] = "6940718dfc3eff4258203ad5021090933e5c04707d5ca8cc9e73c94a7894ea9f"
19
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit setuptools
23
24DEPENDS += " \
25 python-pip \
26"
27
28RDEPENDS_${PN} += " \
29"