summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-01-09 15:14:57 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-01-12 10:38:06 -0500
commit919047dd79f68fa365f7d1b8a43c506fb1f9c8a0 (patch)
treec333ac97e0e0229ca766fc6414a24dffec48eef5 /meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb
parent4ffa2ab9959d7c69d6d2e3faad1a2c8817eceb5d (diff)
downloadmeta-cloud-services-919047dd79f68fa365f7d1b8a43c506fb1f9c8a0.tar.gz
python-ovsdbapp: initial version
Needed by the stable/pike version of python-neutron. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb b/meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb
new file mode 100644
index 0000000..cc1f424
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-ovsdbapp_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "OVSDB application library"
2HOMEPAGE = "https://github.com/openstack/ovsdbapp"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "ovsdbapp"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9
10PV = "0.4.1+git${SRCPV}"
11SRCREV = "742754bce3c9453f8c7186455a92e4f6d6b18ace"
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16# DEPENDS_default: python-pip
17
18DEPENDS += " \
19 python-pip \
20 python-pbr \
21 "
22
23# Satisfy setup.py 'setup_requires'
24DEPENDS += " \
25 python-pbr-native \
26 "
27
28RDEPENDS_${PN} += " \
29 python-fixtures \
30 python-ovs \
31 python-pbr \
32 "