summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2016-01-09 14:27:22 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-01-11 09:33:32 -0500
commit46c95437862c507672e425904b248ad86c938e97 (patch)
tree3a9d9ae46bc2f10992604c2d25218ed59dd80295 /meta-openstack/recipes-devtools/python/python-oslo.service_git.bb
parentd901bade0b2b6b65bd218056658bf028dbde6fbf (diff)
downloadmeta-cloud-services-46c95437862c507672e425904b248ad86c938e97.tar.gz
python-oslo.service: add new recipe to fulfil dependencies
This python module is required for the uprev of nova, trove, neutron, heat... so we are making it available in order to support the pending uprev of these packages as we move to openstack liberty. This python module provides a library for running openstack services. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.service_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.service_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb
new file mode 100644
index 0000000..56384bc
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.service_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "oslo.service library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "0.11.0"
8SRCREV = "3336127916edcd1d94f9bb2df978facb434efa5e"
9
10SRCNAME = "oslo.service"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22RDEPENDS_${PN} += " \
23 python-pbr \
24 "