summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:41:03 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit50fc17c94133022446643f1f577efc468ff72f41 (patch)
treee57c4cbb433809f2f247ca6e13bd64a9e0ba5e9b /meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
parent03e3e1ec39be29e6772e74a8dc25d8164b5ca159 (diff)
downloadmeta-cloud-services-50fc17c94133022446643f1f577efc468ff72f41.tar.gz
python-oslo.reports: initial version
This package is required by nova, heat, cinder and others. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
new file mode 100644
index 0000000..89a83b8
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.reports_git.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "oslo.reports library"
2HOMEPAGE = "https://wiki.openstack.org/wiki/Oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7PV = "0.6.0+git${SRCPV}"
8SRCREV = "31d4a2d9881316f1d2d911a677c0b7556e5040b6"
9
10SRCNAME = "oslo.reports"
11SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
12
13S = "${WORKDIR}/git"
14
15inherit setuptools
16
17DEPENDS += " \
18 python-pip \
19 python-pbr \
20 "
21
22# RDEPENDS_default:
23RDEPENDS_${PN} += " \
24 python-pbr \
25 python-six \
26 python-jinja2 \
27 python-babel \
28 python-psutil \
29 python-oslo.i18n \
30 python-oslo.utils \
31 python-oslo.serialization \
32 "