summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2018-01-09 15:14:58 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2018-01-12 10:38:06 -0500
commit86fc363fc94c69ed195fc3bc61d48de267a6e750 (patch)
treed960f182d8e9c2dd7a6676440deb696745739a10 /meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
parent919047dd79f68fa365f7d1b8a43c506fb1f9c8a0 (diff)
downloadmeta-cloud-services-86fc363fc94c69ed195fc3bc61d48de267a6e750.tar.gz
python-oslo.privsep: initial version
Needed by the stable/pike version of python-neutron. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
new file mode 100644
index 0000000..83504b6
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.privsep_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "OpenStack library for privilege separation"
2HOMEPAGE = "https://github.com/openstack/oslo.privsep"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
6
7SRCNAME = "oslo.privsep"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9
10PV = "1.22.1+git${SRCPV}"
11SRCREV = "d27bb5371c90e0f8b1bdf1bc24f16e1532b3e595"
12S = "${WORKDIR}/git"
13
14inherit setuptools
15
16DEPENDS += " \
17 python-pbr \
18 "
19
20# RDEPENDS_default:
21RDEPENDS_${PN} += " \
22 python-oslo.log \
23 python-oslo.i18n \
24 python-oslo.config \
25 python-oslo.utils \
26 python-enum34 \
27 python-cffi \
28 python-eventlet \
29 python-greenlet \
30 python-msgpack \
31 "