summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <asselsm@gmail.com>2016-02-03 20:40:57 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2016-02-05 14:42:17 -0500
commit3f174923c7da9ec2805672f933e20729f8ed1e7c (patch)
treef57872e0bb8429465b2fd2c3f20981de94f4b627 /meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb
parent38682b461c31c252e2b3647d574727149a7423d4 (diff)
downloadmeta-cloud-services-3f174923c7da9ec2805672f933e20729f8ed1e7c.tar.gz
python-oslo*: convert to 'git' and uprev
These python-oslo* recipes did not previously use git so switching them to make future uprevs simpler. While we are at it uprev to the version required for the liberty release. Signed-off-by: Mark Asselstine <asselsm@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb
new file mode 100644
index 0000000..01a9491
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.policy_git.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Oslo Policy library"
2DESCRIPTION = "The Oslo Policy library provides support for RBAC policy enforcement across all OpenStack services."
3HOMEPAGE = "https://github.com/openstack/oslo.policy"
4SECTION = "devel/python"
5LICENSE = "Apache-2"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1dece7821bf3fd70fe1309eaa37d52a2"
7
8PV = "0.12.0+git${SRCPV}"
9SRCREV = "dee7171326e138128486f1d2c3f7e639af875198"
10
11SRCNAME = "oslo.policy"
12SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools
17
18DEPENDS += " \
19 python-pip \
20 python-pbr \
21"
22
23RDEPENDS_${PN} += " \
24 python-oslo.config \
25 python-oslo.i18n \
26 python-oslo.serialization \
27 python-oslo.utils \
28 python-six \
29 python-requests \
30"