summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-11-07 15:38:38 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-11-08 14:17:24 -0500
commit0a25cc15e836c4bdd8c59f18d690460d62de6cb9 (patch)
treec32601b9df12a2190ef451310d9a99b2eb0cd089 /meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
parentd3d2bd09918f75cd22288795c169a54c4ee8cfaf (diff)
downloadmeta-cloud-services-0a25cc15e836c4bdd8c59f18d690460d62de6cb9.tar.gz
python-oslo*: uprev to latest stable/pike
Uprev all of the existing 'oslo' packages to the latest commit on the stable/pike branch. This will allow us to prepare for the uprev of the main openstack components to stable/pike. Dependencies are been validated and uprev'd/added as needed. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
index a960771..6cd5d76 100644
--- a/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
+++ b/meta-openstack/recipes-devtools/python/python-oslo.messaging_git.bb
@@ -5,10 +5,10 @@ LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=c46f31914956e4579f9b488e71415ac8"
6 6
7SRCNAME = "oslo.messaging" 7SRCNAME = "oslo.messaging"
8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/newton" 8SRC_URI = "git://github.com/openstack/${SRCNAME}.git;branch=stable/pike"
9 9
10PV = "5.10.1+git${SRCPV}" 10PV = "5.30.1+git${SRCPV}"
11SRCREV = "cc1ec4e7f3b395d5f25e7d4922e6359b58a2206a" 11SRCREV = "a07d852b237d229a0f4dd55fd83379c0581e44e9"
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit setuptools 14inherit setuptools
@@ -26,8 +26,6 @@ RDEPENDS_${PN} += " \
26 python-pbr \ 26 python-pbr \
27 python-cachetools \ 27 python-cachetools \
28 python-futurist \ 28 python-futurist \
29 python-oslo.config \
30 python-oslo.context \
31 python-oslo.log \ 29 python-oslo.log \
32 python-oslo.utils \ 30 python-oslo.utils \
33 python-oslo.serialization \ 31 python-oslo.serialization \
@@ -38,8 +36,6 @@ RDEPENDS_${PN} += " \
38 python-debtcollector \ 36 python-debtcollector \
39 python-monotonic \ 37 python-monotonic \
40 python-six \ 38 python-six \
41 python-eventlet \
42 python-greenlet \
43 python-webob \ 39 python-webob \
44 python-pyyaml \ 40 python-pyyaml \
45 python-amqp \ 41 python-amqp \
@@ -47,5 +43,5 @@ RDEPENDS_${PN} += " \
47 python-pika \ 43 python-pika \
48 python-pika-pool \ 44 python-pika-pool \
49 python-futures \ 45 python-futures \
50 python-retrying \ 46 python-tenacity \
51 " 47 "