summaryrefslogtreecommitdiffstats
path: root/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2015-03-02 11:42:33 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2015-03-02 11:42:33 -0500
commit6fef060c2336d4c472c5bc8ec48bfb8a205cd6b3 (patch)
tree334941aa845ae2e605109916f46fe644e6cfa9b0 /meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
parent0a1e95faf0c24e89fdb257cc75fdf1176029a3e9 (diff)
downloadmeta-cloud-services-6fef060c2336d4c472c5bc8ec48bfb8a205cd6b3.tar.gz
kilo: add and update dependency packages
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
Diffstat (limited to 'meta-openstack/recipes-devtools/python/python-oslo.log_git.bb')
-rw-r--r--meta-openstack/recipes-devtools/python/python-oslo.log_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
new file mode 100644
index 0000000..974578b
--- /dev/null
+++ b/meta-openstack/recipes-devtools/python/python-oslo.log_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "Oslo Log Library"
2HOMEPAGE = "https://launchpad.net/oslo"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
6
7PR = "r0"
8
9SRCNAME = "oslo.log"
10SRC_URI = "git://github.com/openstack/${SRCNAME}.git"
11
12PV = "0.3.0"
13SRCREV = "5139941a0c8d63ae33421a2082e35fae0f800b67"
14S = "${WORKDIR}/git"
15
16inherit setuptools
17
18DEPENDS += " \
19 python-pip \
20 python-babel \
21 "
22
23# RDEPENDS_default:
24RDEPENDS_${PN} += " \
25 bash \
26 python-pbr \
27 python-iso8601 \
28 python-oslo.config \
29 python-oslo.context \
30 python-oslo.i18n \
31 python-oslo.utils \
32 python-oslo.serialization\
33 "